Skip to main content

How could I add NAT with private subnet to this Cisco 2500 config?



There's this Cisco 2500 with one V.35 port going to an HDSL DCE, and the ethernet port to a Cisco PIX; there are also other IPs (subnet 80.something) in the configuration on the serial side that are used to route traffic to the DSL provider.



I'm wondering if it is possible to remove the PIX and move everything on the Cisco 2500 - I can usually manage to do this when the public IP is on the wan-facing port and the private IP on the lan one, but I don't know how could I add a private IP to the 2500 and use the public one for nat when they're both on the same internal interface.




The current config for the 2500 looks like:



ip subnet-zero
!
interface Ethernet0
description connected to PIX
ip address 217.x.x.1 255.255.255.248
ip nat inside
no ip directed-broadcast

no ip mroute-cache
no cdp enable
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
encapsulation frame-relay
bandwidth 1024
no cdp enable

!
interface Serial0.1 point-to-point
ip address 80.x.x.x 255.255.255.252
ip nat outside
frame-relay interface-dlci xxx IETF
bandwidth 1024
no ip directed-broadcast
no cdp enable
!
ip classless

ip route 0.0.0.0 0.0.0.0 Serial0.1


The PIX has 217.x.x.2 on its WAN interface and uses the 2500's 217.x.x.1 as default gateway.



I would like to remove the PIX and connect the LAN directly to the Cisco 2500, which would have 192.168.1.1/24 on its Ethernet port and NAT everything out from one of the 217.x.x.X IPs. After that I will probably want to also add other static IPs to the Cisco from the 217.x.x.X/29 subnet and use them to portforward some services to internal servers.


Answer



There's lots of documentation on cisco.com about NAT services.



Try starting at:




http://www.cisco.com/en/US/partner/prod/collateral/iosswrel/ps6537/ps6586/ps6640/prod_qas0900aecd801ba55a.html



As a general guide, you would want 'ip nat outside' on s0/0.1, 'ip nat inside' on e0.



You would make a NAT pool using your 217.x.x.1/29 addresses, that things on the inside could use. They would not appear on an interface anymore.


Comments

Popular posts from this blog

linux - iDRAC6 Virtual Media native library cannot be loaded

When attempting to mount Virtual Media on a iDRAC6 IP KVM session I get the following error: I'm using Ubuntu 9.04 and: $ javaws -version Java(TM) Web Start 1.6.0_16 $ uname -a Linux aud22419-linux 2.6.28-15-generic #51-Ubuntu SMP Mon Aug 31 13:39:06 UTC 2009 x86_64 GNU/Linux $ firefox -version Mozilla Firefox 3.0.14, Copyright (c) 1998 - 2009 mozilla.org On Windows + IE it (unsurprisingly) works. I've just gotten off the phone with the Dell tech support and I was told it is known to work on Linux + Firefox, albeit Ubuntu is not supported (by Dell, that is). Has anyone out there managed to mount virtual media in the same scenario?

hp proliant - Smart Array P822 with HBA Mode?

We get an HP DL360 G8 with an Smart Array P822 controller. On that controller will come a HP StorageWorks D2700 . Does anybody know, that it is possible to run the Smart Array P822 in HBA mode? I found only information about the P410i, who can run HBA. If this is not supported, what you think about the LSI 9207-8e controller? Will this fit good in that setup? The Hardware we get is used but all original from HP. The StorageWorks has 25 x 900 GB SAS 10K disks. Because the disks are not new I would like to use only 22 for raid6, and the rest for spare (I need to see if the disk count is optimal or not for zfs). It would be nice if I'm not stick to SAS in future. As OS I would like to install debian stretch with zfs 0.71 as file system and software raid. I have see that hp has an page for debian to. I would like to use hba mode because it is recommend, that zfs know at most as possible about the disk, and I'm independent from the raid controller. For us zfs have many benefits,

apache 2.2 - Server Potentially Compromised -- c99madshell

So, low and behold, a legacy site we've been hosting for a client had a version of FCKEditor that allowed someone to upload the dreaded c99madshell exploit onto our web host. I'm not a big security buff -- frankly I'm just a dev currently responsible for S/A duties due to a loss of personnel. Accordingly, I'd love any help you server-faulters could provide in assessing the damage from the exploit. To give you a bit of information: The file was uploaded into a directory within the webroot, "/_img/fck_uploads/File/". The Apache user and group are restricted such that they can't log in and don't have permissions outside of the directory from which we serve sites. All the files had 770 permissions (user rwx, group rwx, other none) -- something I wanted to fix but was told to hold off on as it wasn't "high priority" (hopefully this changes that). So it seems the hackers could've easily executed the script. Now I wasn't able